
                                                                                                            

                    

                                                                                                                                   
 

 

 

 

 

 

MST Applet Viewer Java 
Getting Started Guide 

 

 

 

 

 

 

 

 

 

 

 

 

 



Getting Started Guide                                                                                                                                                                

MS Technology Inc.   2 
 

 

 

 

 

 

 

 

 

Copyright © 2013 MS Technology. All rights reserved. 

This guide and accompanying software are confidential and proprietary to MS Technology. No part of this 
document can be copied, modified, reproduced, republished, uploaded, or distributed in any form by any 
means without prior authorization of MS Technology. Unauthorized use of the information appearing here 
may violate copyright, trademark and other applicable laws, and could result in criminal or civil penalties. 

The information provided in this document is used as a guide only and is subject to change without any 
notice. MS Technology reserves the rights to change and update their product or make changes in the context 
without any obligation to notify any person for such changes. 

MS Technology,                                                                                                                                 

P.O. Box 471843                                                                                                  
Charlotte, NC 28247                                                      

USA 

Tel: 704-544-3403                                                                                                                  
Fax: 704-544-0262                                                                                                                                  

Email: info@ms-technology.com                                                                                                          
Website: www.ms-technology.com 

If there is any typographical error in this manual, or has any thought of a way to make this manual better, we 

would love to hear, feel free to share with us at info@ms-technology.com.  

 

mailto:info@ms-technology.com
http://www.ms-technology.com/


Getting Started Guide                                                                                                                                                                

MS Technology Inc.   3 
 

Table of Contents 

Introduction .................................................................................................................................................. 5 

Getting Started with MST Applet Viewer Java .............................................................................................. 6 

About MST Applet Viewer............................................................................................................................. 7 

Install MST Applet Viewer ............................................................................................................................. 8 

System Requirements ............................................................................................................................... 8 

Configuration .............................................................................................................................................. 10 

On Client Side ............................................................................................. Error! Bookmark not defined. 

On Server Side ......................................................................................................................................... 11 

With ECM Repository .............................................................................................................................. 12 

Installation .................................................................................................................................................. 15 

Create WAR ............................................................................................................................................. 15 

Deployment through Apache Tomcat Server ......................................................................................... 16 

Deployment through IBM Web Sphere .................................................................................................. 17 

Setting JVM Memory and Arguments in WebSphere ......................................................................... 21 

Deployment through Red Hat JBoss ....................................................................................................... 21 

Understanding Interface ............................................................................................................................. 23 

Working with Working Sets ........................................................................................................................ 29 

Append Documents in Working Sets ...................................................................................................... 29 

Save Document ........................................................................................................................................... 29 

Print Document ........................................................................................................................................... 30 

Annotations ................................................................................................................................................. 31 

Line .......................................................................................................................................................... 31 

Rectangle ................................................................................................................................................ 31 

Circle ....................................................................................................................................................... 31 

Arrow ...................................................................................................................................................... 31 

Highlighter ............................................................................................................................................... 31 

Pen .......................................................................................................................................................... 32 

Text ......................................................................................................................................................... 32 

Stamp ...................................................................................................................................................... 32 

Sticky Note .............................................................................................................................................. 32 



Getting Started Guide                                                                                                                                                                

MS Technology Inc.   4 
 

Redaction ................................................................................................................................................ 32 

Shortcut Keys .............................................................................................................................................. 33 

Advantages .................................................................................................................................................. 34 

 



Getting Started Guide                                                                                                                                                                

MS Technology Inc.   5 
 

Introduction 

If you have just a few minutes or want to know just the basics, this is the place to start. This guide 
provides a basic overview of using MST Applet Viewer.  

This guide has been designed in such a way that the user is able to understand the software in an 
efficient and effective manner. MST recommends users to carefully go through the guide before 
launching the product and keep it in a safe, easily accessible place for future reference. 
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Getting Started with MST Applet Viewer Java 

This guide covers how to get start with MST Applet Viewer. After reading this guide, the reader will 
know: 

 The general overview of MST Applet Viewer 

 

 How to install MST Applet Viewer 

 

 How to work with the Graphical User Interface of MST Applet Viewer, the menu options 
that are available in the viewer, and the functions they perform 

 

 How to open/view documents in the viewer 

 

 How to work with Working Sets 

 

 How to save documents in the viewer 

 

 Overview of annotations 
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About MST Applet Viewer 

MST Applet Viewer is an innovative thin-client, web-based version of the MST Viewer for .NET. It 
has all the great features and benefits of the MST Viewer for .NET. It is an image and document 
viewer that operates seamlessly on the Java platform and provides a vast array of standard features 
and functions as well as industry-specific options to meet the entire imaging requirements of an 
Enterprise Content Management (ECM) system. It is an applet viewer that enables users to view, 
manipulate, convert, annotate, and print documents and image file formats located in ECM from a 
single application.  
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Install MST Applet Viewer  

Before continuing further with the installation, please make sure that the system that the viewer will 
be deployed on meets the minimum system requirements. This section will guide the administrator 
on how to install the product.  

System Requirements 

This section provides the minimum and recommended requirements for running MST Applet 
Viewer: 

Workstation Requirements 

Operating System 

 Windows XP  

 Windows Vista (32 & 64 Bit Versions) 

 Windows 7 (32 & 64 Bit Versions) 

 Windows 8 (32 & 64 Bit Versions) 

 MAC OSX 

 LINUX 

Compatible Internet Browsers 

 Microsoft IE 6 or higher 

 Chrome 15 or higher 

 Mozilla Firefox 4 or higher 

 Apple Safari 4.5 or higher 

 Opera 7 or higher 

Prerequisite 

JRE 1.5 or higher 

Minimum Workstation System Requirements 

 Processor: Intel Pentium 4 1.0 GHz or higher, AMD Athlon 1.0 GHz or higher 

 RAM: 512 MB 

 100 MB of available hard-disk space for installation 

 500 MB of additional hard-disk space for cache 

Recommended Workstation System Requirements 

 Processor: Intel Pentium 4 2.0 GHz or higher, AMD Athlon 2.0 GHz or higher 
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 RAM: 1GB 

 100 MB of available hard-disk space for installation 

 

Server Requirements 

Operating System 

 Windows Server 2003 (32 & 64 Bit Versions) 

 Windows Server 2008 R2 (32 & 64 Bit Versions) 

 LINUX (RHEL or SUSE) 

Application Server 

 Apache Tomcat 5.5.9 or higher 

 JBoss 4.0 or higher 

 IBM Web Sphere 6.1 or higher 

 Oracle Web Logic 9.0 or higher 

 Oracle Glass Fish 

Minimum System Requirements 

 Processor: Intel Pentium 4 2.0 GHz or higher, AMD Athlon 2.0 GHz or higher 

 RAM: 4 GB 

 100 MB of available hard-disk space for installation 

Recommended System Requirements 

 Processor: Intel Pentium 4 2.0 GHz or higher, AMD Athlon 2.0 GHz or higher 

 RAM: 8 GB 

 250 MB of available hard-disk space for installation 
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Configuration 

This section explains how to configure the MST Applet Viewer on the workstation and server. 

Workstation: 

1. Create Java Policy File in the current user directory. 
2. Set the memory for the applet viewer. To do this, perform the following steps: 

 Click Start -> Control Panel -> Java. 

 Click the Java tab. 

 

 Click View. 

 The Java Runtime Settings dialog box appears. 
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 Provide the required memory in the Java Runtime Parameter field. 

 Click OK. 

Server: 

1. Open MSTViewer.jsp. 
2. Configure the Port Number, Context and IP address of the Web/App server on which the 

MST Applet Viewer is configured. 

<param name="Context" value="MSTViewer"> 

<param name="IP" value="192.168.10.22:8080"> 

// Application Name 

Context=MSTViewer 

// IP address and Port No. of the machine where 

“MSTViewer” is running. 

IP=192.168.10.22:8080 

3. Set the configureTempPath attribute value in web.xml file to configure the temporary file 
path for the PDF documents. 

<context-param> 

     <param-name>configureTempPath</param-name> 

     <param-value>C:\Images\Temp\</param-value> 

</context-param> 
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With the ECM Repository 

Configuration of MST Applet Viewer with the Server Local File 
System 

1. Open mstconfig.properties text file provided under …\MSTViewer\WEB-INF\classes. 
2. Provide the values in the below attributes: 

filesystem.repository.Drive=C:/ 

filesystem.repository.Library=Images 

This would be for where  

           “C” is the drive name and  

            “Images” is the folder name in C drive.  

Place the sample files in the “C:/Images” folder 

 

Configuration of MST Applet Viewer with SharePoint Repository 

1. Open mstconfig.properties text file provided under …\MSTViewer\WEB-INF\classes. 
2. Provide the values in the below attributes: 

sharepoint.IP=192.168.10.30:120/SPWebIntegrator 

This would be for where  

           “192.168.10.30” is an IP address and  

           “120” is the port number where MSDocService is running 

3. Test MSDocService. For this, provide below complete URL with the service name in the 
browser from the server machine where application server is running. 

http://192.168.10.30:120/ SPWebIntegrator/MSDocService.asmx  
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Configuration of MST Viewer with Documentum Repository 

1. Open mstconfig.properties text file provided under …\MSTViewer\WEB-INF\classes. 
2. Provide the values in the below attributes: 

documentum.repository.cabinetNames=documentum:mst:System:Resourc

es  

mst.repository.repositoryName=documentum 

This would be for where  

           “documentum”, “mst”,”System” and “Resource” are the cabinet names of the ECM. 

 The administrator can change the above values in the “documentum.repository.cabinetNames” 
attribute with any cabinet name which resides in the “Cabinets” root directory. 

 “documentum” is the doc base name (repository name) of “mst.repository.repositoryName” attribute 
in Documentum ECM. 

3. Open dfc.properties text file provided under …\MSTViewer\WEB-INF\classes. 
4. Provide the values in the below attributes: 

dfc.docbroker.host[0]=WEBTOP 

dfc.docbroker.port[0]=1489 

dfc.globalregistry.repository=documentum 

This would be for where  

           “WEBTOP” is the computer name,  

“1489” is the port number where documentum service is running and  

“documentum” is the ECM repository name 
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Configuration of MST Viewer with IBM FileNet Repository 

1. Open filenetConfiguration.properties text file provided under …\MSTViewer\WEB-
INF\classes. 

2. Provide the values in the below attributes: 

WorkPlace_URL=http://mf451:9080  

            This would be for where  

 “mf451” is the machine name or IP Address and  

           “9080” is the port Number of Application Server on which Filenet is configured. 

3. Go to the directory in which application.war is placed (e.g. “C:\Program 
Files\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\mf451Node01Cell\
Workplace.ear\app_engine.war”). 

4. Make a lib folder and place all the four jar files named activation.jar, mail.jar, mailapi.jar 
and MSTViewer.jar. 

5. Place MSTClient.jsp at location “C:\Program 
Files\IBM\WebSphere\AppServer\profiles\AppSrv01\installedApps\mf451Node01Cell\
Workplace.ear\app_engine.war” and change the following parameters: 

<param name="Context" value="MSTViewer"> 

<param name="IP" value="192.168.10.57:8080"> 

 This would be for where  

“MSTViewer” is the name of application that is deployed and  

The IP is the IP Address of the system, including Port Number, of Application Server 

6. Open content_redir.properties text file provided under “C:\Program 
Files\FileNet\Config\AE\”. 

7. Change the filename of the JSP file to MSTViewer.jsp corresponding to those MIME types 
that are to open in the MST Viewer. 

For Example: 

image/tiff=/MSTViewer.jsp?{JSP_QUERY_STRING} 

application/pdf=/MSTViewer.jsp?{JSP_QUERY_STRING} 

8. To load the viewer, forward the request from ExecuteSearch.jsp to MSClientServer.jsp 
with parameters objectStoreName, userName, password, docid. 
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Installation 

Before starting the installation of the MST Applet Viewer, download the application zip file to the 
server that the viewer will be deployed on. The following are the steps to assist the administrator 
with installing the viewer. 

1. Extract the MST Viewer zip file. 
2. The folder contains sub folders:  

 Images 

 Lib 

 OcrDll 

 WEB-INF 

 LoginPage.htm 

 MS_SCAN.dll 

 MS_SCAN.tlb 

 MSBrowseDetect.js 

 MSMainDocument.jsp 

 MSTViewer.jsp 

 MSTURL.js 

 RegisterScandll.bat 

 twain.dll 

 twain_32.dll 

 Un-RegisterScandll.bat 

 validateDocList.jsp 

Create WAR 

1. Open the Command Prompt. 
2. Execute the following jar command to create jar file: 

 jar - cvf “MSTViewer.war” *.* 

3. The jar file should now be created inside the MST Viewer folder. 
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Deployment with Apache Tomcat Application Server 

Perform the following steps to deploy MSTViewer.war with Apache Tomcat Application Server: 

1. Click Start -> Programs -> Apache Tomcat 5.5 -> Tomcat Manager to launch Tomcat 
Manager. 

2. Use the WAR file to deploy option from Tomcat Manager to deploy MSTViewer.war file. 
3. For Office 97-2003 Support: 

 For a Window Server: Place all deliverable files from the Office dll's\Windows\v32 for 
Windows 32 bit systems or from Office dll's\Windows\v64 for Windows 64 bit systems in 
the IBM\WebSphere\AppServer1\bin folder. 

 For Linux Server: Copy the installation package from Office dll's\Linux to Red Hat 
Enterprise Linux systems and run the install.sh shell script.  

 This will install Office engine libraries to /usr/lib directory. 

4. Open Configure Tomcat provided from Start -> Programs -> Apache Tomcat 5.5 -> 
Configure Tomcat to set the memory for the application. 

5. The Apache Tomcat Properties dialog box appears. 
6. Go to Java tab. 
7. Set the memory for the application from the Initial Memory Pool. 

 



Getting Started Guide                                                                                                                                                                

MS Technology Inc.   17 
 

8. Go to the General tab. 
9. Click Start to start the Tomcat Application Server. 
10. Click OK. 

 

Deployment with IBM WebSphere 

Perform the following steps to deploy the MSTViewer.war with IBM WebSphere:  

1. For Office 97-2003 Support 

 For Window Server: Place all deliverable files from the Office 
Dll's\Windows\v32 for Windows 32 bit systems or from Office Dll's\Windows\v64 for 
Windows 64 bit systems in the IBM\WebSphere\AppServer1\bin folder. 

 For Linux Server: Copy the installation package from Office Dll's\Linux to Red 
Hat Linux machine and run the install.sh shell script.  

 This will install Office engine libraries to /usr/lib directory. 

2. Start WebSphere Application Server 6.1, by going to Start -> Programs -> IBM 
WebSphere -> Application Server v 6.1 -> Profiles -> AppSrv01 -> Start the server. 
 

3. Open Administrative Console by  going to Start -> Programs -> IBM WebSphere -> 
Application Server v 6.1 -> Profiles -> AppSrv01 -> Administrative Console.  
 

4. The Integrated Solutions Console screen appears. 
 

 
 

5. Provide the User ID and Password in the respective fields. 
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6. The home screen will appear. 
7. Go to Applications -> Install New Application. 

 
 

 
 

8. Click Browse and navigate to the path where the MSTViewer.war file is stored. 
9. Provide the value in the Context root field. 

 

 
 

10.   Click Next. 
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11. Select Installation Options from the list of available options for installing enterprise     
application. 

12. Click Next. 
 

 
 
13. Select the checkbox to map modules to server. 
14. Click Next. 

 

 
 
15. Select the checkbox to map virtual host for web modules. 
16. Click Next. 
17. Click Finish. 
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18. Click Save to save master configuration. 
19. Start the MST Viewer Web Application by going to Applications -> Enterprise 

Application. 
20. Select the MSTClient-Server.war checkbox. 

 

 
 

21. Click Start to start MST Viewer application. 
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Setting JVM Memory and Arguments in WebSphere 

The JVM memory settings must be changed for production environments and/or when processing 
large volume in non-production. 

The WebSphere application server’s memory size but be adjusted to operate correctly. Perform the 
following steps to set the JVM memory size. 

1. Connect to the WebSphere administrative console by using the following URL: 

     http://WebSphere Host:WebSphere Admin Port/admin 

 The default WebSphere administrative console ports are 9060, 9061 or 9080. 

2. Select Servers -> Application Servers. 
3. Select the correct server name. 
4. Go to Server Infrastructure, and then click Java and Process Management. 
5. Select Process Definition. 
6. Go to Additional Properties, and then click Java Virtual Machine. 
7. Enter 1280 for Maximum Heap Size (depends upon requirement). 
8. Enter “-Xjit:disableLocalVP, disableGlobalVP” for Generic JVM arguments. 
9. Click OK. 
10. Click Save to commit the setting. 

Deployment with Red Hat JBoss 

Perform the following steps to deploy the MSTViewer.rar with Red Hat JBoss: 

1. For Office 97-2003 Support 

 For Window Server: Place all deliverable files from Office Dll's\Windows\v32 for 
Windows 32 bit servers or from Office Dll's\Windows\v64 for Windows 64 bit servers in 
the 
/opt/IBM/WebSphere/AppSCellerver/profiles/AppSrv01/installedApps/RHLWS7
Node01 folder. 

 For Linux Server: Copy the installation package from Office Dll's\Linux to Red 
Hat Linux machine and run the install.sh shell script. 

  This will install Office engine libraries to /usr/lib directory. 

2. Place the application war file to the following path of JBoss Server: 
 

  JBOSS_HOME\server\default\deploy\ 

3. Remove xml-apis.jar, xercesImpl.jar, servlet-api.jar from MSTViewer package 
(MSTViewer/WEB-INF/lib). 
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4. Set the environment variable in JBoss 

Djboss.vfs.forceCaseSensitive=true  

Djboss.vfs.forceVfsJar=true 

 It will be look like this: 

set "JAVA_OPTS=-Djboss.vfs.forceCaseSensitive=true -  

Djboss.vfs.forceVfsJar=true” 

5. Configure JVM Memory Settings 

Run the bat file in the bin folder that contains the JVM parameters that includes the memory 
configuration. From the production server, confirm that these values are correctly set. For 
example, the following sets the minimum and maximum heap size as 1GB.  

set JAVA_OPTS=%JAVA_OPTS% -Xms1024m -Xmx1024m 

It is a good idea to keep these identical for performance reasons. The actual heap size setting 
will depend on the application requirements and also on the RAM available of the server 
machine. 

6. Run run.bat file to start JBoss Server. The path to run the file is: 

 JBOSS_HOME\bin\run.bat 
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Understanding Interface 

The MST Applet Viewer interface is user friendly, and provides quick access to all important 
functions the user needs.  

                           

  

 

The following are the components of the application user interface. 

 Menu Bar: The top most bar of the application interface that contains all the available 
features of the application. It has eight menu options: 

o File  
o Edit  
o View  
o Image  
o Bookmarks 
o Image Operations 
o Annotation  
o Help  

 

Menu Bar Toolbar 

Annotation Toolbar Document View Area Thumbnail View 
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Menu Options Options Description 

 
 
 
 
 
 
 
 
 

File 

  
 
 

 

New Document: Creates a 
new Working Set 
Append Document: Appends 
documents in a Working Set 
Save: Saves an active document 
with its current filename and 
location  
Save As: Saves an active 
document to another location 
with the same or different 
filename 
Print: Prints an active 
document 
Print Preview: Shows how the 
file will look when it will print 
Close: Closes an active 
document 
Close All: Closes all opened 
documents 
Exit: Closes all opened 
documents and quit application 

 
 
 
 
 
 

 
Edit 

 
 
 

 

Cut Page: Cuts the selected 
text or image from a page 
Copy Page: Copies the 
selected text or image from a 
page 
Paste Page: Inserts the copied 
text or image at the insertion 
point (cursor) 
Redo: Redo a previously 
undone change 
Undo: Reverses the effect of 
the most recent image editing 
or filtering operation 
Delete Page: Deletes selected 
document from the Working 
Set 
PDF Text Search: Searches 
text in a PDF file 
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View 

 
 
 
 

 

First Page: Display the first 
page of an active document 
Previous Page: Display the 
previous page of an active 
document 
Next Page: Display the next 
page of an active document 
Last Page: Display the last 
page of an active document 
Go To Page: Go to the 
specified page of a document 
Operation Toolbar: Display 
the operation tool bar 
Status Bar: Display the Status 
bar 
Thumbnails: Display the 
thumbnail view of the 
documents opened in a 
Working Set 
Ruler: Display ruler on the 
page 
Hide Annotations: Hide 
annotation toolbar and option 
from the menu bar 
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Image 

 
 
 
 
 
 
 

 
 
 
 
 
 

 

Enhance: Magnify the view of 
the page of a document 
Zoom In: Increases the 
magnification percentage of a 
document 
Zoom Out: Decreases the 
magnification percentage of a 
document 
Custom Zoom: Resize the 
document with a specified size 
Actual Size: Bring the 
document in its actual size 
Fit in Window: Resize the 
document to fit entirely in the 
window 
Fit To Width: Resize the 
document to fit the width of 
the window 
Fit To Height: Resize the 
document to fit the height of 
the window 
Rotate Right: Rotate the page 
of an active document in a 
clockwise direction 
Rotate Left: Rotate the page of 
an active document in an 
anticlockwise direction 
Rotate 180 degrees: Rotate the 
page of an active document in a 
180° direction 
Image Magnifier: Magnifies a 
specific part of an image 
Split Window: Divide 
documents either horizontally 
or vertically  
Redact Page: Redactions will 
not move and will be saved 
permanently  
Image Properties: Displays 
properties of an image 
 

 
 
 
 
 
 

 
 
 
 
 
 

 
 
 
 
 
 



Getting Started Guide                                                                                                                                                                

MS Technology Inc.   27 
 

 
 
 
 
 
 
 
 
 
 

Bookmarks 

 
 
 
 
 
 

 

Add Bookmark: Add 
bookmark to an active page of 
a document 
Add Multiple Bookmark: 
Add multiple bookmarks on a 
document 
Remove Bookmark: Remove 
added bookmark from a 
document 
First Bookmark: Display first 
bookmark in a document 
Next Bookmark: Display next 
bookmark in a document 
Previous Bookmark: Display 
previous bookmark in a 
document 
Last Bookmark: Display last 
bookmark in a document 
Go to Bookmark: Go to the 
specified bookmark in a 
document 
Remove All Bookmark: 
Delete all the added bookmarks 
in a document 

 
 
 
 
 
 
 
 
 

Image 
Operations 

 
 
 
 

 
 

Image Filters: Apply various 
effects on an image 
Edge Detections: Identifying 
and locating sharp 
discontinuities in an image 
Flips: Rotate image either 
vertically, horizontally or 
diagonally 
Brightness/Contrast: Change 
the brightness and contrast of 
an image 
Emboss: Emboss an image 
Invert Image: Invert color of 
an image 
Sharpness: Makes an image 
sharper 
Smoothness: Makes an image 
smoother  
Initial Image: Bring an image 
into its actual look  
RedEye: Appearance of red 
pupil in the eyes of humans and 
animals 
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Help 

 
 

Help: Open user manual for 
assistance 
About: Check the product 
version and licensing 
information 

 Toolbar: The MST Applet Viewer has floating toolbars with several buttons that can be 
easily accessed to quickly perform any action. The toolbars can be dragged to any location to 
prevent obstructing the view of the document. The toolbars can also be temporarily hidden 
by going to: View -> Toolbars. 
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Working with Working Sets 

A Working Set is a collection of documents that can be viewed as one continuous document.  
Working Sets enable users to:  

 View multiple documents in a single document window.  

 Browse documents and pages from Tree-View or Thumbnail. 

 Scan documents and add them into a working set. 

 Create custom documents in a working set which can be converted to single or multi-page 
documents. 

 

Append Documents in Working Sets 

Within a working set, documents can be appended to the current working set by performing the 
following steps: 

1. On the File menu, click Append Document. 
2. The Select Location dialog box appears. 
3. Navigate to find the desired file and click Append. 
4. If the selected file is supported will be opened in the viewer. 
5. Repeat the process to append another document to the working set. 

 

Save Document 

The document can be saved in a number of file formats to the user’s workstation (if they have 
permission), to a folder on a network drive, or back to the ECM repository. MST Applet Viewer 
supports saving files to the following formats: 

 WBMP 

 TIFF 

 JPEG 

 GIF 

 Bitmap 

 MODCA 

 IOCA 

 PDF 
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Perform the following steps to save a document: 

1. From the File menu, click Save or click the Save button displayed in the Standard toolbar. 

 

Perform the following steps to save a document in a different format: 

1. Click Save As button displayed on the Standard toolbar or select Save As from the File 
Menu. 

2. From the dialog box, in the navigation pane (the left pane), select the folder to where the 
document needs to be saved to. 

3. In File Name box, enter the name of the file. 
4. From Select as type drop down box, select the new file format type of the document. 
5. Select one of the following required save options from the list: 

 Current Page: Save the current page only.  

 Current Document: Save all pages of the current document. 

 Pages: Save some specified pages, and then enter the page numbers using arrow keys.  

6. Click Settings for BMP Compressions. 
7. Once done, click Save to save the document in a different format. 

 

Print Document 

Documents can be printed by performing the following steps: 

1. While viewing a document, from the File menu, click Print. 
2. Once the Print dialog box is displayed, from the Printer group, select the printer to use (if it 

is not selected). 
3. From the Print Range group, specify the portion of the document that the user wants to 

print. If the user clicks on Pages, they have to enter the page numbers or range to print. 
4. From the Copies group, select the number of copies of the document to print. 
5. To adjust page settings, go to Page Setup tab. 
6. Once done, click OK. 
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Annotations 

Annotations are comments, notes, explanations, or other types of external remarks that can be 
added to a document to provide additional information or emphasis. 

The MST Applet Viewer provides tools to enable the user to freely write their own comments to the 
document to collaborate with others. It provides the ability to add comments via sticky notes, apply 
digital stamps, and much more, making MST Applet Viewer an ideal solution for business 
workflows. It also allows the user to save, copy, paste and print annotations. 

Annotation marks are saved within a unique file that stores the annotation data. When the user 
makes an annotation, a file with the same name, with an extension .t_l is created in the same 
directory. Any annotation that is NOT burned-in (embedded) is put into this file. The .t_l file is a 
GOCA type file. These marks can also be merged with the image data in a process known as 
“burned-in”. Once annotations are burned-in a document, they become part of the base image and 
cannot be manipulated by the annotation functions.  

MST Applet Viewer has a full range of annotation tools for users. The following is a list of the 
annotation and markup tools included in the viewer, with a description of their functionality. 

Line 

This annotation tool draws a horizontal, vertical, or lines at 45° with adjustments: color, thickness, 
and transparency.  

Rectangle 

This annotation tool draws a rectangle with adjustments: line and fill color, thickness, and 
transparency. 

Circle 

This annotation tool draws a circle with adjustments: line and fill color, thickness, and transparency. 

 

Arrow 

This annotation tool draws a horizontal, vertical or 45° arrow with adjustments: color, thickness, 
arrowhead length and angle. 

Highlighter 

This annotation tool provides the ability for the user to highlight an area or text of a document. 
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Pen 

This annotation tool draws freehand lines and shapes with adjustments: color, thickness, and 
transparency. 

Text 

This annotation tool enters text with adjustments: size and color of the fonts and the text box. 

Stamp 

The user can stamp images and/or text anywhere on a document. The user can choose either from a 
list of predefined stamps or create their own stamps.  

Sticky Note 

Post notes to documents that standout to other users. Sticky Notes enable users to create text notes 
for easier collaboration between team members. 

Redaction 

This annotation tool is used to hide sensitive/confidential information of a file or document.  
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Shortcut Keys 

Short Cut keys provide an easier and quicker method of navigating and using software. Short Cut 
keys are commonly accessed by using ALT, CTRL, or SHIFT in conjunction with a single letter. 

The following shortcut keys that will work with all PC compatible computers and software programs 
and it is highly recommended that all users keep a good reference of them.  

 

Command Short Cut Key 

Open  Ctrl + O  

Close  Ctrl + W  

Close All Documents  Ctrl + Shift + W  

Save As  F12  

Print  Ctrl + P  

Cut  Ctrl + X  

Copy  Ctrl + C  

Paste  Ctrl + V  

Insert Page  Insert  

Delete Selected  Delete  

Delete Document  Ctrl + Delete  

Delete All Document  Ctrl + Shift + Delete  

Select All Pages  Ctrl + Shift + A  

Deselect All Pages  Ctrl + Shift + D  

Crop Page  Ctrl + Shift + C  

First Page  Home  

Previous Page  Page Up  

Last Page  End  

Next Page  Page Down  

Go To Page  Ctrl + G  

First document  F7  

Next Document  Ctrl + Page up  

Last Document  Ctrl + Page Down  

Previous Document  F8  

Thumbnails  Ctrl + F11  

Hide Annotations  F11  

Enhance  Ctrl + E  

Zoom In  +  

Zoom Out  -  

Custom Zoom  Ctrl + M  

Actual Size  Shift + A  

Fit in Window  Shift + F  

Fit to Width  Shift + W  

Fit to Height  Shift + H  
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Rotate Right  Ctrl + Arrow Right  

Rotate Left  Ctrl + Arrow Left  

Rotate 180  Ctrl + Arrow Down  

Invert  Ctrl + Alt + I  

Magnifying Lens  Alt + L  

Image Properties  Ctrl + Alt + Enter  

Pen  Ctrl + Alt + P  

Highlighter  Ctrl + Alt + H  

Rectangle  Ctrl + Alt + R  

Circle  Ctrl + Alt + C  

Line Ctrl + Alt + L  

Arrow Ctrl + Alt + A  

Sticky Note Ctrl + Alt + N  

Stamp Ctrl + Alt + S 

Text Ctrl + Alt + T  

 

Advantages 

 Reduce Overhead and Increase Productivity: Allows companies to reduce a number of 
applications to one efficient universal document and image viewer.  

 File Formats: Supports over 75 common and proprietary file formats. 

 Email and Fax: Email and/or fax images and documents directly from the viewer.  

 Annotations: Access to a number of different annotations including, but not limited to 
redaction, line, arrow, rectangle, circle, text, note, highlighter, pen stamp, watermark and 
eraser. 

 Internal Development: All file formats are developed by in-house MST developers and do 
not use any third party APIs. This allows MST to provide customizations, prompt 
resolutions to issues, and release control. 

 Individual Release Control: Reduces deployment and upgrade cost. Every customer has 
their own release version of the product. 


